[fait] lenteurs

Le forum pour ceux qui sont hébergés sur le serveur Lapin. Les pauvres !
Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

[fait] lenteurs

Message non lupar Phiip the only Phiip » lun. 12 janv. 2009 - 13:51

La lenteur du serveur tous les soirs est étrange.
Il n'y a pas plus de visiteurs maintenant qu'avant le crash,
alors, que s'est-il passé ?

Des idées ?

On cause aussi ici du cache de la page d'accueil (LH).
Modifié en dernier par Phiip the only Phiip le mer. 04 févr. 2009 - 12:47, modifié 1 fois.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » mar. 13 janv. 2009 - 00:43

Hop hop hop je travail sur un petit cache rapide pour la page d'accueil en ce moment même.

Du coup on verra bien si ça va changer les choses.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » mar. 13 janv. 2009 - 01:51

Heu Phiip, je me pose une question :
Lorsque je me connecte via le ssh, j'ai accès a Lapin-sos. Pas au master. C'est normal ?
Je suspecte que sur le ftp pareil.
En fait, pour tester, j'ai modifié légèrement la page d'accueil.
Puis je l'ai supprimée.

Ben c'est toujours là le Lapin. (oui, oui, je la remet quand même dans le doute la page index.html :D )

Là aussi : c'est normal ?

Ptètre faudrait voir ça avec Philippe ?

(du coup, il a pas voulu de mon test de cache :( )

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » mar. 13 janv. 2009 - 07:35

Ben normalement non... le master est à l'adresse 192.168.0.21 normalement, au lieu de 22.

Mais demandons à Philippe comment être sûrs...

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » mar. 13 janv. 2009 - 08:17

C'est qui, Philippe ?
Je suis le seul vrai lapin du forum

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » mar. 13 janv. 2009 - 23:47

C'est la personne à qui tu dois demander pour tes problèmes de mail !!!

Avatar de l’utilisateur
Jeannot
quintessence ultime
Messages : 4938
Enregistré le : lun. 25 nov. 2002 - 21:49

Message non lupar Jeannot » mer. 14 janv. 2009 - 04:46

De toutes façons, s'il n'y a pas de solution, c'est qu'il n'y a pas de problème.
Mourir un Vendredi Saint est une bonne chose, car ce jour là, l'Enfer est fermé.

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » jeu. 15 janv. 2009 - 07:08

Ben... Philippe nous a dépanné, mais la réalité, c'est que je n'ai pas d'admin système en fait...

Styx était motivé à un moment, non ?

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » jeu. 15 janv. 2009 - 23:42

Je vais lui redemander, mais je crois qu'il avait pas mal surestimé le temps disponible quand t'es élève à l'ENS cachan. Je peux me tromper, mais les derniers mots que j'ai eu de lui online étaient grosso modo : "pas l temps, j'bosse".

Après, Lapin, c'est bien, il sera tenté c'est certain.

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » ven. 16 janv. 2009 - 07:58

J'ai ce message avec le cache :

Code : Tout sélectionner

Warning: file_put_contents(cache/cache.html) [function.file-put-contents]: failed to open stream: Permission denied in /var/www/domains/lapin/www/index.html on line 442

Et après, la page s'affiche.
Je n'ai accès au ftp qu'en local sinon.

Edit : ah si, là ça marche.

Edit : heu, quel est le délai de rafraichissement de la page ? Les mises à jour n'apparaissent pas même une heure après.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » sam. 17 janv. 2009 - 02:49

hahahha

ouais

ok je corrige ça après Bourne

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » sam. 17 janv. 2009 - 11:17

Sinon, ben, ça semble marcher, hein !
Et félicitation pour le recrutement de Jason Bourne;
Il s'y connaît en serveur ?

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » dim. 18 janv. 2009 - 06:56

Qui est Jason Bourne ?
Je suis le seul vrai lapin du forum

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » dim. 18 janv. 2009 - 10:47

Un informaticien il semblerait...

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » dim. 18 janv. 2009 - 16:25

Tu devais pas être là ce week-end, lahyenne ?
Y'a certainement des trucs à compléter sur la page d'accueil, elle reste souvent lente.

Y'aurait-il une table qui se remplit trop ?

Comment détecter une requête qui traine trop ?

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » lun. 19 janv. 2009 - 15:02

Accessoirement, il faut réécrire la page d'accueil.
J'ai déjà viré plusieurs requêtes (zine, forum) mais je pense que c'est presentation-strips.php qui buggue.

Il faudrait s'y atteler.
Peux-tu faire ça, Lahyenne ?

Sinon, pour compléter le message au-dessus,
quand j'éteins et que je rallume le serveur,
tout repart très vite.
Une table de sessions quelque part bugguerait-elle ?

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » lun. 19 janv. 2009 - 21:42

J'étais là ce week end.
Mais j'ai bossé tout le week end en fait.
Sincèrement Phiip, ce semestre va être extrêmement plein pour moi, j'aurais vraiment peu de temps à accorder à Lapin.

La page d'accueil est en cours de création, mais il faut pas rêver, il y en a pour longtemps, ce ne sera pas pour demain. presentation-strips est lourd, ça fait un moment qu'on le sait.

Un test pour savoir ce qui est lent dans la page d'accueil est d'afficher le timing (qui se calcule pour toute la page) régulièrement dans la page. Après chaque requète. Comme ça t'auras une idée de ce qui rame.
Mais effectivement, c'est pas la peine de chercher, presentations-strips fait je crois deux requetes pour chaque strip... donc ca commence à en faire un paquet. D'ici dix jours, je devrais avoir un truc qui marche mieux.
Priez LAPINS ! MOUAHAHAHAH.

LH

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » mar. 20 janv. 2009 - 07:03

En fait, le problème (mais tu l'avais noté) c'est que lapin se retrouve en fait sans informaticien.
Et sans informaticien, ben, ça peut pas marcher...

Comment fonctionne ton cache ?

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » mar. 20 janv. 2009 - 19:48

J'ai doublé la mémoire vive du serveur (deux fois 1 Go).
J'ai divisé presentation-strips.php en deux.

Le résultat semble correct...
A voir sur le moyen terme.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » mar. 20 janv. 2009 - 21:59

Le cache est un truc vraiment bricolé.
Il crée une page html toutes les x minutes et utilise ensuite la page html.

Note que j'ai toujours pas accès en ssh alors je ne peux rien changer.
Tu peux changer le temps en modifiant la valeur dans le test du début du script. Il faut le mettre à pas beaucoup et ça devrait suffir.

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » mer. 21 janv. 2009 - 07:00

Et si on y va deux fois moins souvent, on s'en rend deux fois moins compte. Ça divise pas deux l'énervement, l'anxiété et le besoin d'avaler les crayons.

Y a-t-il une explication au fait que le soir, ça ne marche quasiment pas ?
Je suis le seul vrai lapin du forum

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » dim. 01 févr. 2009 - 00:23

Maintenant c'est mieux, Joh ?

Avatar de l’utilisateur
Jeannot
quintessence ultime
Messages : 4938
Enregistré le : lun. 25 nov. 2002 - 21:49

Message non lupar Jeannot » dim. 01 févr. 2009 - 02:06

C'était mieux avant.
Mourir un Vendredi Saint est une bonne chose, car ce jour là, l'Enfer est fermé.

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » dim. 01 févr. 2009 - 08:28

LaHyenne a écrit :Maintenant c'est mieux, Joh ?

Oui, il me semble. Cela dit, je viens rarement le soir, du coup.
Je vais essayer.



** Attend patiemment ce soir **
Je suis le seul vrai lapin du forum

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » dim. 01 févr. 2009 - 18:20

Y'avait une limitation du nombre de connexions simultanées dans la configuration du serveur.
En l'augmentant, on a tout simplement résolu le problème.

Et voilà !

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » dim. 01 févr. 2009 - 18:48

Vous êtes parfaits.

On est le soir ?






ON EST LE SOIR !!!!
Je suis le seul vrai lapin du forum

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » lun. 02 févr. 2009 - 07:01

Hééééé oui !

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Message non lupar LaHyenne » dim. 08 févr. 2009 - 04:40

s'évanouit.
On est le soir !!!
Mais heu, pas à la meme heure :D

Bon ben c'est cool.
Je réalise que je ne suis pas venu depuis deux semaines sur le forum.

Et donc, que voici quelques explication.


- Travail.
- Oh ?
- Béh ouais
- Oh ?
- Ouais oh, hé c'est bon, hein ?
- Allez quoi, pas travail quand même ?
- Ben, si, travail.
- Et heu... c'est tout ?
- Ah ben ouais.
- Comme ca, rien d'autre, piscine ? Sport ? glande ?
- non travail, c'est tout.
- Meme le week end ?
- hah, surtout le week end !
- Déconne ?
- Allez va. Retourne a ta bière. J'ai encore trois projets à finir.
- Trois ?
- Pour lundi.
- lundi ?
- ouais.
- Ouais ?

Et donc, ben voila, c'est de pire en pire (ou de mieux en mieux parceque j'adore ce que je fait) et j'ai de moins en moins de temps à consacrer a autre chose. Je ne suis pas alle au dessin vivant cette semaine. Je ne met plus a jour mon blog. Je ne me rase plus. Je me lave un jour sur deux pour gagner du temps. Je baise en trois minutes chrono et de toutes facon je bosse en meme temps parce que faut pas déconner.








Ou pas.

LH

PS : Bisous !!!

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Message non lupar Phiip the only Phiip » dim. 08 févr. 2009 - 09:44

Oh... je sens que c'est le moment de poser cette question : comment remettre en place l'url rewriting ?
On a plein de messages d'erreur, là, des gens issus des moteurs de recherche...

Avatar de l’utilisateur
Johnny
ourse verte
Messages : 5705
Enregistré le : ven. 22 nov. 2002 - 23:17

Message non lupar Johnny » lun. 09 févr. 2009 - 08:48

Copier, puis coller.


De rien.
Je suis le seul vrai lapin du forum


Retourner vers « la tanière du serveur Lapin [privé] »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité