Pour le probleme d'encodage

Le forum pour ceux qui sont hébergés sur le serveur Lapin. Les pauvres !
Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 08:26


Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 08:54

Je suis en train de bosser dessus phiip
ptin regler ce pb une bonne fois pour toute

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 10:01

Ok presque resolu.

Phiip, il FAUT que tu verifies que tu encodes bien les fichiers en utf-8 sans BOM.

Et il va rester des points d'interrogation a changer, c'est force, vu qu'on a genre 6 ou 7 ans de iso 8859 derriere nous.
Ptin je vais dormir la.

claque.
Dis moi si tu vois des modifs importantes a faire vite.

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » lun. 28 déc. 2009 - 11:23

Oui, mais 'sans BOM', ça veut dire quoi ?
Bon je vais, heu... refaire du fichier, hein.

Et pourquoi les ?

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » lun. 28 déc. 2009 - 14:12

Heu... je dois refaire tous les fichiers lapin de tous les strips ?

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 17:54

Non.

je vais essayer de trouver une conversion.
Mais faut etre conscients que la on part de loin...

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 17:56

iconv -f encodage_original -t utf-8 fichier_original > nouveau_fichier

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » lun. 28 déc. 2009 - 18:33

Bon, je l'ai fait sur Les céré���est pas trop mieux...
J'ai fait tout nadine et les fichiers à � �c�
�a�j�eux modifier un comm', j'ai :
"Warning: Cannot modify header information - headers already sent by (output started at /var/www/domains/lapin/comics/cereales/nadine/modify_comments2.php:2) in /var/www/include/admin_modify_comments_check.php on line 37"

C'est lié ?�(si�n,� p�x �ifi�un�rip, ça m�che t�jou�
(et �est�per g�re.�n peut�as a�r certai� fic�rs comm� dan�e include au lieu de dans nadine ?)

Comme d'ahb', j'ai repéré les bugs :
-�e� sur ce post (?�)� dans histoir�r�dente/histoire �i�nte sur Céréales ;
�d�s la �b�irie (f� �fe, hein,�a� que ça reste fon�o�l ç�!)

Je continue mon �ploratio�

Et j'ai des gros t��les noirs avec des ?�dans plein mon admin toujours dans céréales.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 18:54

heu test accent ? éè

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 21:09

Ok pour le zine. Puree deux heures pour jouer avec les fichiers.
Et rien n'est resolu.
Muahahaha j'y arriverait

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 22:21

Okay j'ai trouve pour le zine

Archive :

Code : Tout sélectionner

for i in *; do
 if [ -f "$i" ]; then
   echo "$i"
   iconv -f ISO-8859-1 -t UTF-8 "$i" > "${i}2"
   mv "${i}2" "$i"
 fi
done


et je vais faire des tests pour la bdd (avec sauvegarde totale avant of course)

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » lun. 28 déc. 2009 - 22:31

for i in *; do if [ -f "$i" ]; then echo "$i"; iconv -f ISO-8859-1 -t UTF-8 "$i" > "${i}2"; mv "${i}2" "$i"; fi; done

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » mar. 29 déc. 2009 - 08:08

J'essaye : ééééééé où été les kiwis ?

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » mar. 29 déc. 2009 - 08:08

Ooooooooooh...

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » mar. 29 déc. 2009 - 12:43

J'ai vu ton message avant de partir !
J'espère que ça va marcher, parce que là, le Zine est en plein encodage-aaargh !

Sinon, les comms foirent (peut-être faire la manip' que tu as faite sur index_functions ?)
(voir céréales et dissonance)
On a des doublons aussi. Je ne sais pas pourquoi.
Peut-être par notre faute, comme on a sauvegardé à la même période, ils ont dû avoir du mal à poster en même temps.

Forum : on va le confirmer dans vingt secondes.
Edit : ça marche de mon boulot !

Avatar de l’utilisateur
Phiip the only Phiip
Le type qui fait les lapins, là...
Messages : 13019
Enregistré le : lun. 26 août 2002 - 17:48

Re: Pour le probleme d'encodage

Message non lupar Phiip the only Phiip » mar. 29 déc. 2009 - 13:39

Je ne sais pas si c'est lié, j'ai ça en mettant à jour ninja :

"Warning: fopen(../time.laststrip) [function.fopen]: failed to open stream: Permission denied in /var/www/include/admin_functions.php on line 207

Warning: fputs(): supplied argument is not a valid stream resource in /var/www/include/admin_functions.php on line 208

Warning: fclose(): supplied argument is not a valid stream resource in /var/www/include/admin_functions.php on line 209
Mise à jour des méta données aussi (en douce, hein, faut pas déconner).

1261762009126204120012620412001262041200126204120012620412001262041200126204120012620412001262041200
Warning: fopen(../fluxrss.xml) [function.fopen]: failed to open stream: Permission denied in /var/www/include/maj_rss.php on line 63

Warning: fputs(): supplied argument is not a valid stream resource in /var/www/include/maj_rss.php on line 64

Warning: fclose(): supplied argument is not a valid stream resource in /var/www/include/maj_rss.php on line 65
Export XML effectue !
Voir le fichier"

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 17:37

ah oui, j'ai manipule des fichiers en root
desole, c'est regle (pour tous)


Et pour les encodages, on est dessus.
Par contre, j'aurais besoin du mot de passe de la bdd (le root, hein, pas le tien)
Et le filer a elfi via jabber aussi, ca pourrait servir

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 18:57

for i in *.php; do if [ -f "$i" ]; then echo "$i"; sed -i s/è/è/g $i; sed -i s/é/é/g $i; sed -i s/ç/ç/g $i; sed -i s/É/É/g $i; sed -i s/î/î/g $i; fi; done

pour changer les caracteres over-encodes

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 19:05

"Ã " => "à",
"â" => "â",
"ç" => "ç",
"è" => "è",
"é" => "é",
"ê" => "ê",
"ë" => "ë",
"î" => "î",
"ï" => "ï",
"ô" => "ô",
"ù" => "ù",
"û" => "û",

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 19:50

Librairie entierement corrigee (me prevenir si bugs)

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 22:17

for i in *.php; do if [ -f "$i" ]; then echo "$i"; sed -i s/è/è/g $i; sed -i s/é/é/g $i; sed -i s/ç/ç/g $i; sed -i s/â/â/g $i; sed -i s/î/î/g $i; sed -i s/ï/ï/g $i; sed -i s/ù/ù/g $i; sed -i s/û/û/g $i; sed -i "s/à /à/g" $i; fi; done

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 22:39

Zine 100% restauré.
Me prévenir si erreurs.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mar. 29 déc. 2009 - 23:38

J'ai foire dans l'encyclo, images corrompues.
A reuploade s'il vous please !

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 00:27

Strips okay

Plus qu'un bug etrange sur la page d'accueil du portail.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 02:03

L'ensemble de dotclear / portail a ete reconverti.
Il doit resterdes erreurs (qui viennent de loin celles la, apparement ya un troiseme jeu de caractere qui avait ete introduit (windows quelque chose, tu connais ?) )

Mais grosso modo il ne reste plus qu'un truc :
LEs imports de la base de donnee ajoutent des merdes et je sais pas pourquoi, mais je vais trouver.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 05:27

Solution de fortune temporaire :
utilisation de utf8_decode sur les affichages qui merdent sur la page d'accueil de lapin.

Pour l'instant on va en rester la, mais il y a quelque chose de pas clair, un double encodage utf8 qui fait foirer.
Bref, retour a la normale pour, je crois a peu pres tout.

Me dire sinon.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 20:05

Putain c'est pas du tout resolu pour les strips !
Gniiiiiiii

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 20:25

YEEEEEE
je crois que j'ai trouve.
Stay tuned, mais la, j'ai bon espoir.

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 20:27

mysql_set_charset('utf8');

require_once "inc/bdd_connect.php";

Avatar de l’utilisateur
LaHyenne
ourse verte
Messages : 8140
Enregistré le : sam. 08 mars 2003 - 01:58

Re: Pour le probleme d'encodage

Message non lupar LaHyenne » mer. 30 déc. 2009 - 20:48

Puree j'espere que c'est la derniere fois que je me tape tous les fichiers xinougly a changer un a un :D


Retourner vers « la tanière du serveur Lapin [privé] »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité